summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorZephyron <zephyron@citron-emu.org>2025-02-01 21:47:03 +1000
committerZephyron <zephyron@citron-emu.org>2025-02-01 21:47:03 +1000
commit076d0e618dcab0e7d02c416350e991e8e207e03d (patch)
tree853a904da3dff2a10971b4ee234427ba387fbc39 /CMakeLists.txt
parentecc32958ec1a14f48d51ac48001b3b7e101d994c (diff)
build: update Qt to 6.8.1 and add permissive flag for discord-rpc
Updates the Qt dependency from 6.7.3 to 6.8.1 when downloading Qt. Adds -fpermissive compile flag for discord-rpc target to fix build issues.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 73a4ea2d1..3465b7f73 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -419,7 +419,7 @@ add_subdirectory(externals)
if (ENABLE_QT)
if (NOT USE_SYSTEM_QT)
- download_qt(6.7.3)
+ download_qt(6.8.1)
endif()
find_package(Qt6 REQUIRED COMPONENTS Widgets Multimedia Concurrent Network)
@@ -673,3 +673,5 @@ if(ENABLE_QT AND UNIX AND NOT APPLE)
install(FILES "dist/org.citron_emu.citron.metainfo.xml"
DESTINATION "share/metainfo")
endif()
+
+target_compile_options(discord-rpc PRIVATE -fpermissive)