summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMai <mai.iam2048@gmail.com>2022-12-11 21:09:52 +0000
committerGitHub <noreply@github.com>2022-12-11 21:09:52 +0000
commit0c531ff911606cdbed0ea1865fd8beb9a3f45874 (patch)
tree54851b76928d53e58528b6bf5464f6095ca6e6f7 /CMakeLists.txt
parentd5684dbe7d7a562a79e267350ef9a45f23dfb817 (diff)
parent8d1d6e149f4929227b00084f7a14f4c701348119 (diff)
Merge pull request #9419 from liamwhite/no-gl
cmake: make OpenGL loader optional
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 16f31b3a6..47eddf99e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -22,6 +22,8 @@ CMAKE_DEPENDENT_OPTION(YUZU_USE_BUNDLED_SDL2 "Download bundled SDL2 binaries" ON
# On Linux system SDL2 is likely to be lacking HIDAPI support which have drawbacks but is needed for SDL motion
CMAKE_DEPENDENT_OPTION(YUZU_USE_EXTERNAL_SDL2 "Compile external SDL2" ON "ENABLE_SDL2;NOT MSVC" OFF)
+option(ENABLE_OPENGL "Enable OpenGL" ON)
+mark_as_advanced(FORCE ENABLE_OPENGL)
option(ENABLE_QT "Enable the Qt frontend" ON)
option(ENABLE_QT6 "Allow usage of Qt6 to be attempted" OFF)
set(QT6_LOCATION "" CACHE PATH "Additional Location to search for Qt6 libraries like C:/Qt/6.3.1/msvc2019_64/")