summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorZephyron <zephyron@citron-emu.orgq>2025-03-03 16:35:57 +1000
committerZephyron <zephyron@citron-emu.orgq>2025-03-03 16:35:57 +1000
commit1308e2b935f6ef0451686336192b6502fdeccb9e (patch)
tree6f19879cfd60d06888ca2be648e4b0d8507f9216 /CMakeLists.txt
parent5caecd815155aacb316b155c1353f5ab69cd1913 (diff)
CMake: Enable C++ latest and coroutines for MSVC builds
Add /std:c++latest and /await compiler flags for MSVC builds to enable the latest C++ features and coroutine support.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 542fce810..e35fec4df 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,7 +14,7 @@ include(CTest)
# Disable Warnings as Errors for MSVC
if (MSVC)
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} /W3 /WX-")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} /W3 /WX- /std:c++latest /await")
endif()
# Check if SDL2::SDL2 target exists; if not, create an alias