summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorZephyron <zephyron@citron-emu.org>2025-01-15 19:20:37 +1000
committerZephyron <zephyron@citron-emu.org>2025-01-15 19:20:37 +1000
commit132077e18f491d12d305e94f594470d6b93e8d8d (patch)
tree656c8f3a0e79756914fe3314ae34f37733afc238 /CMakeLists.txt
parent236ad28d61d94d0848c863e2cefa168f75813f49 (diff)
fix: Implement SetGestureOutputRanges to handle unimplemented function error
- Added the SetGestureOutputRanges function to the IHidServer class to address the unimplemented function '92' error. - This fix was discovered through log analysis, which showed a critical assertion failure in the HID service for an unknown function '92'. - The log indicated a userspace panic and backtrace, pointing to the need for implementing this function to prevent execution breaks. - Updated CMakeLists.txt to remove specific version requirements for several packages, enhancing flexibility. - Updated subproject commit references for VulkanMemoryAllocator and vcpkg. - REF: https://switchbrew.org/wiki/HID_services#ActivateGesture
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 7 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5f1fabf78..23df5afc0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -310,21 +310,21 @@ set(CMAKE_RUNTIME_OUTPUT_DIRECTORY ${PROJECT_BINARY_DIR}/bin)
# =======================================================================
# Enforce the search mode of non-required packages for better and shorter failure messages
-find_package(Boost 1.79.0 REQUIRED context)
-find_package(enet 1.3 MODULE)
+find_package(Boost REQUIRED context)
+find_package(enet MODULE)
find_package(fmt 9 REQUIRED)
if (CITRON_USE_LLVM_DEMANGLE)
- find_package(LLVM 17.0.2 MODULE COMPONENTS Demangle)
+ find_package(LLVM MODULE COMPONENTS Demangle)
endif()
find_package(lz4 REQUIRED)
-find_package(nlohmann_json 3.8 REQUIRED)
-find_package(Opus 1.3 MODULE)
+find_package(nlohmann_json REQUIRED)
+find_package(Opus MODULE)
find_package(RenderDoc MODULE)
find_package(SimpleIni MODULE)
find_package(stb MODULE)
find_package(VulkanMemoryAllocator CONFIG)
-find_package(ZLIB 1.2 REQUIRED)
-find_package(zstd 1.5 REQUIRED)
+find_package(ZLIB REQUIRED)
+find_package(zstd REQUIRED)
if (NOT CITRON_USE_EXTERNAL_VULKAN_HEADERS)
find_package(VulkanHeaders 1.3.274 REQUIRED)