summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorZephyron <zephyron@citron-emu.org>2025-02-09 18:57:35 +1000
committerZephyron <zephyron@citron-emu.org>2025-02-09 18:57:35 +1000
commit13ada2d705137483f7004374438135d2a918e578 (patch)
tree23853495b000c65ad871bb4ea88616cb18e6cf45 /CMakeLists.txt
parent8bf4660bacdb800158a73155feea72c4d0873673 (diff)
cmake: Use Qt 6.7.3 for MSVC builds
Forces Qt 6.7.3 for MSVC builds while keeping 6.8.2 for other platforms. This fixes Windows compilation issues with newer Qt versions.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8c4e4d3c4..b5bf1a978 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -422,7 +422,11 @@ endif()
if (ENABLE_QT)
if (NOT USE_SYSTEM_QT)
- download_qt(6.8.2)
+ if ((MSVC_VERSION GREATER_EQUAL 1920) AND ARCHITECTURE_x86_64)
+ download_qt(6.7.3)
+ else()
+ download_qt(6.8.2)
+ endif()
endif()
find_package(Qt6 REQUIRED COMPONENTS Widgets Multimedia Concurrent Network)