summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorZephyron <zephyron@citron-emu.org>2025-02-10 19:55:16 +1000
committerZephyron <zephyron@citron-emu.org>2025-02-10 19:55:16 +1000
commit33d54e595f8623e5d8814815c8663857d8e5cc2d (patch)
tree24870f44bcfaa9f85e41ae75332e74f18bd58747 /CMakeLists.txt
parent13ada2d705137483f7004374438135d2a918e578 (diff)
cmake: update Qt configuration and externals URL
- Simplify Qt version selection to always use 6.8.2 instead of conditional versions - Update bundled externals URL to use git.citron-emu.org/Citron - Update MSVC toolchain references from 2019 to 2022 for Qt paths This change streamlines Qt version management and updates the infrastructure to use newer MSVC toolchain paths.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 1 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b5bf1a978..8c4e4d3c4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -422,11 +422,7 @@ endif()
if (ENABLE_QT)
if (NOT USE_SYSTEM_QT)
- if ((MSVC_VERSION GREATER_EQUAL 1920) AND ARCHITECTURE_x86_64)
- download_qt(6.7.3)
- else()
- download_qt(6.8.2)
- endif()
+ download_qt(6.8.2)
endif()
find_package(Qt6 REQUIRED COMPONENTS Widgets Multimedia Concurrent Network)