summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorZephyron <zephyron@citron-emu.org>2025-01-27 13:25:16 +1000
committerZephyron <zephyron@citron-emu.org>2025-01-27 13:25:16 +1000
commit33f8cd0c7ee521bf23506a791e88367d5129161e (patch)
tree4e12ccfe218cbeb93329b49a8793dd3c6ef73a2b /CMakeLists.txt
parentc5a2689ceff33343a8be623bdd1687486db78123 (diff)
deps: Update Vulkan dependencies and remove fmt version constraint
- Update Vulkan-Headers to e43027a (1.4.306) - Update Vulkan-Utility-Libraries to 8ec8482 - Update vcpkg to 2b8927f - Remove version constraint for fmt package requirement - Update VulkanHeaders version requirement to 1.4.306 This updates several external dependencies to their latest versions and removes the specific version requirement for fmt while maintaining the REQUIRED flag. The Vulkan-Headers version requirement is updated to match the new submodule version.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0d8706d5c..73a4ea2d1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -312,7 +312,7 @@ set(CMAKE_RUNTIME_OUTPUT_DIRECTORY ${PROJECT_BINARY_DIR}/bin)
# Enforce the search mode of non-required packages for better and shorter failure messages
find_package(Boost REQUIRED context)
find_package(enet MODULE)
-find_package(fmt 9 REQUIRED)
+find_package(fmt REQUIRED)
if (CITRON_USE_LLVM_DEMANGLE)
find_package(LLVM MODULE COMPONENTS Demangle)
endif()
@@ -327,7 +327,7 @@ find_package(ZLIB REQUIRED)
find_package(zstd REQUIRED)
if (NOT CITRON_USE_EXTERNAL_VULKAN_HEADERS)
- find_package(VulkanHeaders 1.4.304 REQUIRED)
+ find_package(VulkanHeaders 1.4.306 REQUIRED)
endif()
if (NOT CITRON_USE_EXTERNAL_VULKAN_UTILITY_LIBRARIES)