summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJames Rowe <jroweboy@gmail.com>2018-09-20 21:39:15 -0600
committerGitHub <noreply@github.com>2018-09-20 21:39:15 -0600
commit8606995515757e7528380877cf44d6ffd4560266 (patch)
treebe11300e23bd1eb7d8d8ff4838f43ae7b6633145 /CMakeLists.txt
parent000da01c1d8ad19435babf40be0a9db283920ecb (diff)
parent189cf0da7b5d1f3905558956be64f7292e753000 (diff)
Merge pull request #1225 from tech4me/travis-windows
travis: running mingw build on travis ci
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt17
1 files changed, 13 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 500d099fc..30642edd7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -269,10 +269,18 @@ if (YUZU_USE_BUNDLED_UNICORN)
find_package(PythonInterp 2.7 REQUIRED)
- add_custom_command(OUTPUT ${LIBUNICORN_LIBRARY}
- COMMAND ${CMAKE_COMMAND} -E env UNICORN_ARCHS="aarch64" PYTHON="${PYTHON_EXECUTABLE}" /bin/sh make.sh macos-universal-no
- WORKING_DIRECTORY ${UNICORN_PREFIX}
- )
+ if (MINGW)
+ add_custom_command(OUTPUT ${LIBUNICORN_LIBRARY}
+ COMMAND ${CMAKE_COMMAND} -E env UNICORN_ARCHS="aarch64" PYTHON="${PYTHON_EXECUTABLE}" /bin/sh make.sh cross-win64
+ WORKING_DIRECTORY ${UNICORN_PREFIX}
+ )
+ else()
+ add_custom_command(OUTPUT ${LIBUNICORN_LIBRARY}
+ COMMAND ${CMAKE_COMMAND} -E env UNICORN_ARCHS="aarch64" PYTHON="${PYTHON_EXECUTABLE}" /bin/sh make.sh macos-universal-no
+ WORKING_DIRECTORY ${UNICORN_PREFIX}
+ )
+ endif()
+
# ALL makes this custom target build every time
# but it won't actually build if LIBUNICORN_LIBRARY is up to date
add_custom_target(unicorn-build ALL
@@ -286,6 +294,7 @@ endif()
if (UNICORN_FOUND)
add_library(unicorn INTERFACE)
+ add_dependencies(unicorn unicorn-build)
target_link_libraries(unicorn INTERFACE "${LIBUNICORN_LIBRARY}")
target_include_directories(unicorn INTERFACE "${LIBUNICORN_INCLUDE_DIR}")
else()