summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorZephyron <zephyron@citron-emu.org>2025-01-14 15:33:24 +1000
committerZephyron <zephyron@citron-emu.org>2025-01-14 15:33:24 +1000
commit9ae0eeeb870899e00121b01380d9699b6e768d34 (patch)
treea6db1f6ea1b4a0eb662493220d82d6e7653e0799 /CMakeLists.txt
parentd028ac291c4f281ac6edc937bcbd0ad385ae031c (diff)
Revert incorrect copyright attribution for non-contributed files
- In commit b3facaa6bb30cdc39f2b7d632fef1e3bfeee7785, the copyright header was updated to include "Citron Homebrew Project" across multiple files, regardless of whether any contributions were made. - This commit removes the incorrect attribution and reverts the copyright header to its previous state. - Copyright attribution should only be added when meaningful contributions have been made to the file. - This commit ensures proper compliance with copyright standards and maintains correct attribution to the respective contributors. - Special thanks to Tachi for pointing out the need for these corrections and ensuring that proper attribution practices are followed.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt19
1 files changed, 13 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 199232f84..a210c682b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,4 +1,4 @@
-# SPDX-FileCopyrightText: 2025 Citron Homebrew Emulator Project & vampiric_x 2025
+# SPDX-FileCopyrightText: 2025 Citron Homebrew Emulator Project
# SPDX-License-Identifier: GPL-2.0-or-later
cmake_minimum_required(VERSION 3.22)
@@ -655,10 +655,17 @@ if(ENABLE_QT AND UNIX AND NOT APPLE)
DESTINATION "share/metainfo")
endif()
-# Set default x86-64-v2 instruction set for better compatibility
+# Set CPU architecture compatibility flags
if (CMAKE_SYSTEM_PROCESSOR MATCHES "x86_64|amd64|AMD64")
- # Ensure quotes are preserved and flags are set for both main build and vcpkg
- set(ISA_FLAGS "-march=x86-64-v2")
+ # Default to x86-64 baseline for maximum compatibility
+ set(ISA_FLAGS "-march=x86-64")
+
+ # Allow override via CMake option
+ option(CITRON_USE_X86_64_V2 "Enable x86-64-v2 instruction set" OFF)
+
+ if(CITRON_USE_X86_64_V2)
+ set(ISA_FLAGS "-march=x86-64-v2")
+ endif()
# Set for main project
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${ISA_FLAGS}")
@@ -668,8 +675,8 @@ if (CMAKE_SYSTEM_PROCESSOR MATCHES "x86_64|amd64|AMD64")
set(VCPKG_CXX_FLAGS "${ISA_FLAGS}")
set(VCPKG_C_FLAGS "${ISA_FLAGS}")
- # Set toolchain options for vcpkg
- set(VCPKG_CHAINLOAD_TOOLCHAIN_FILE "${CMAKE_CURRENT_SOURCE_DIR}/cmake/x86-64-v2-toolchain.cmake")
+ # Set toolchain options for vcpkg
+ set(VCPKG_CHAINLOAD_TOOLCHAIN_FILE "${CMAKE_CURRENT_SOURCE_DIR}/cmake/x86-64-toolchain.cmake")
# Ensure we're not getting overridden by system defaults
add_compile_options(${ISA_FLAGS})