summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorliamwhite <liamwhite@users.noreply.github.com>2023-02-27 19:46:19 -0500
committerGitHub <noreply@github.com>2023-02-27 19:46:19 -0500
commita78a475815ee20d448fb75db7707d52e974041a2 (patch)
tree3b615fa636a30d183eae2813f350787016eb2edd /CMakeLists.txt
parent22432668be6d34b5a5275bcc631cadf512f36bf9 (diff)
parent2bf9602e83715264cc438feeccf102d76bc98b76 (diff)
Merge pull request #9844 from abouvier/jwt-fix
cmake: fix cpp-jwt build
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 274eebe8a..906073602 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -244,6 +244,9 @@ endif()
if (ENABLE_WEB_SERVICE)
find_package(cpp-jwt 1.4 CONFIG)
find_package(httplib 0.12 MODULE)
+ if (NOT cpp-jwt_FOUND OR NOT httplib_FOUND)
+ find_package(OpenSSL 1.1 MODULE COMPONENTS Crypto SSL)
+ endif()
endif()
if (YUZU_TESTS)