summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMatías Locatti <42481638+goldenx86@users.noreply.github.com>2023-02-27 01:01:44 -0300
committerMatías Locatti <matias.locatti@gmail.com>2023-02-27 18:44:14 -0300
commitc38bb96a2c1e3b9e536584403e2acd9623b02b92 (patch)
tree669d22640971cde2d9142a0011e9d47bce023157 /CMakeLists.txt
parent26c1edf2f083399a594a834bdd36be85369819f7 (diff)
Partially apply LTO to only core and video_core projects.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 10a3de9e2..274eebe8a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -56,6 +56,8 @@ option(YUZU_USE_BUNDLED_VCPKG "Use vcpkg for yuzu dependencies" "${MSVC}")
option(YUZU_CHECK_SUBMODULES "Check if submodules are present" ON)
+option(YUZU_ENABLE_LTO "Enable link-time optimization" OFF)
+
CMAKE_DEPENDENT_OPTION(YUZU_USE_FASTER_LD "Check if a faster linker is available" ON "NOT WIN32" OFF)
if (YUZU_USE_BUNDLED_VCPKG)