summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRiver City Ransomware <richyateswebdesign@gmail.com>2018-01-19 19:36:09 -0500
committerbunnei <bunneidev@gmail.com>2018-01-19 19:36:09 -0500
commitc8a094e164b77fdae6b4b8bff7f94b703c24c161 (patch)
tree7f1f70cec7f189c022b9ed5dc03c4996d21e54ca /CMakeLists.txt
parent0b6da0c1abaa34a082b627dfe909b6651d8b6fee (diff)
Port citra #3352 to yuzu (#103)
* Port citra #3352 to yuzu This change allows non x86_64 architectures to compile yuzu by skipping the building of dynarmic * Fixed clang-format errors * fixes more clang-format errors
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt19
1 files changed, 11 insertions, 8 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index aa2154cb1..4b27e0c5b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -54,15 +54,18 @@ function(detect_architecture symbol arch)
endif()
endfunction()
-if (MSVC)
- detect_architecture("_M_AMD64" x86_64)
- detect_architecture("_M_IX86" x86)
- detect_architecture("_M_ARM" ARM)
-else()
- detect_architecture("__x86_64__" x86_64)
- detect_architecture("__i386__" x86)
- detect_architecture("__arm__" ARM)
+if (NOT ENABLE_GENERIC)
+ if (MSVC)
+ detect_architecture("_M_AMD64" x86_64)
+ detect_architecture("_M_IX86" x86)
+ detect_architecture("_M_ARM" ARM)
+ else()
+ detect_architecture("__x86_64__" x86_64)
+ detect_architecture("__i386__" x86)
+ detect_architecture("__arm__" ARM)
+ endif()
endif()
+
if (NOT DEFINED ARCHITECTURE)
set(ARCHITECTURE "GENERIC")
set(ARCHITECTURE_GENERIC 1)