summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEmmanuel Gil Peyrot <linkmauve@linkmauve.fr>2016-07-23 17:10:32 +0100
committerEmmanuel Gil Peyrot <linkmauve@linkmauve.fr>2016-07-23 17:10:32 +0100
commite09e6837208a5cda81c0eee233f301433201cb8b (patch)
tree3c5626f34d796c29108a325f44422482aabf4796 /CMakeLists.txt
parent624cd9cd983e294cea77a337e8aed916f28ababe (diff)
Remove the -msse4.1 on ¬MSVC.
This option makes the generated binary crash with an illegal instruction when the target CPU doesn’t support the SSE4.1 extension (see #1968), with no noticeable performance increase compared to a generic build.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 0 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9a436b981..779eb8e50 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -66,11 +66,6 @@ message(STATUS "Target architecture: ${ARCHITECTURE}")
if (NOT MSVC)
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++1y -Wno-attributes")
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS}")
-
- if (ARCHITECTURE_x86_64)
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -msse4.1")
- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -msse4.1")
- endif()
else()
# Silence "deprecation" warnings
add_definitions(/D_CRT_SECURE_NO_WARNINGS /D_CRT_NONSTDC_NO_DEPRECATE /D_SCL_SECURE_NO_WARNINGS)