summaryrefslogtreecommitdiff
path: root/externals/CMakeLists.txt
diff options
context:
space:
mode:
authorlat9nq <22451773+lat9nq@users.noreply.github.com>2021-04-16 19:12:47 -0400
committerlat9nq <22451773+lat9nq@users.noreply.github.com>2021-04-16 19:12:47 -0400
commit12e58917c0280ef8dcb2e94cd9a02bac03c3d27a (patch)
tree057653e34546b3055e653e48847642526c727d01 /externals/CMakeLists.txt
parentbb32a4a8d7790dff557ea893229579eddb525ac5 (diff)
externals: Add SDL 2.0.12
Since Bintray is (soon to be) no more, there needs to be a way to acquire SDL2. Since 20.04's version is older than our minimum required version (2.0.12), add it as an external.
Diffstat (limited to 'externals/CMakeLists.txt')
-rw-r--r--externals/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/externals/CMakeLists.txt b/externals/CMakeLists.txt
index 891a47c3c..6e4591b4e 100644
--- a/externals/CMakeLists.txt
+++ b/externals/CMakeLists.txt
@@ -45,6 +45,12 @@ target_include_directories(microprofile INTERFACE ./microprofile)
add_library(unicorn-headers INTERFACE)
target_include_directories(unicorn-headers INTERFACE ./unicorn/include)
+# SDL2
+if (NOT SDL2_FOUND)
+ set(SDL2_FOUND YES)
+ add_subdirectory(SDL EXCLUDE_FROM_ALL)
+endif()
+
# SoundTouch
add_subdirectory(soundtouch)