summaryrefslogtreecommitdiff
path: root/externals/CMakeLists.txt
diff options
context:
space:
mode:
authorZephyron <zephyron@citron-emu.org>2024-12-31 17:07:49 +1000
committerZephyron <zephyron@citron-emu.org>2024-12-31 17:07:49 +1000
commitb3facaa6bb30cdc39f2b7d632fef1e3bfeee7785 (patch)
tree77d03cd30542cd5e1addc61f240b8120a5909e90 /externals/CMakeLists.txt
parent6778aa8ec8e5fa0d246ac4b9ec00c10213c30ce5 (diff)
chore: update project references and add Citron copyright
- Replaced all references to the old project name with Citron. - Added Citron copyright information alongside existing notices in all files.
Diffstat (limited to 'externals/CMakeLists.txt')
-rw-r--r--externals/CMakeLists.txt14
1 files changed, 7 insertions, 7 deletions
diff --git a/externals/CMakeLists.txt b/externals/CMakeLists.txt
index d49a2e43e..117683423 100644
--- a/externals/CMakeLists.txt
+++ b/externals/CMakeLists.txt
@@ -63,11 +63,11 @@ if (ENABLE_LIBUSB AND NOT TARGET libusb::usb)
endif()
# SDL2
-if (YUZU_USE_EXTERNAL_SDL2)
+if (CITRON_USE_EXTERNAL_SDL2)
if (NOT WIN32)
- # Yuzu itself needs: Atomic Audio Events Joystick Haptic Sensor Threads Timers
+ # Citron itself needs: Atomic Audio Events Joystick Haptic Sensor Threads Timers
# Since 2.0.18 Atomic+Threads required for HIDAPI/libusb (see https://github.com/libsdl-org/SDL/issues/5095)
- # Yuzu-cmd also needs: Video (depends on Loadso/Dlopen)
+ # Citron-cmd also needs: Video (depends on Loadso/Dlopen)
# CPUinfo also required for SDL Audio, at least until 2.28.0 (see https://github.com/libsdl-org/SDL/issues/7809)
set(SDL_UNUSED_SUBSYSTEMS
File Filesystem
@@ -142,7 +142,7 @@ if (NOT TARGET Opus::opus)
endif()
# FFMpeg
-if (YUZU_USE_BUNDLED_FFMPEG)
+if (CITRON_USE_BUNDLED_FFMPEG)
add_subdirectory(ffmpeg)
set(FFmpeg_PATH "${FFmpeg_PATH}" PARENT_SCOPE)
set(FFmpeg_LDFLAGS "${FFmpeg_LDFLAGS}" PARENT_SCOPE)
@@ -151,12 +151,12 @@ if (YUZU_USE_BUNDLED_FFMPEG)
endif()
# Vulkan-Headers
-if (YUZU_USE_EXTERNAL_VULKAN_HEADERS)
+if (CITRON_USE_EXTERNAL_VULKAN_HEADERS)
add_subdirectory(Vulkan-Headers)
endif()
# Vulkan-Utility-Libraries
-if (YUZU_USE_EXTERNAL_VULKAN_UTILITY_LIBRARIES)
+if (CITRON_USE_EXTERNAL_VULKAN_UTILITY_LIBRARIES)
add_subdirectory(Vulkan-Utility-Libraries)
endif()
@@ -210,7 +210,7 @@ endif()
# Breakpad
# https://github.com/microsoft/vcpkg/blob/master/ports/breakpad/CMakeLists.txt
-if (YUZU_CRASH_DUMPS AND NOT TARGET libbreakpad_client)
+if (CITRON_CRASH_DUMPS AND NOT TARGET libbreakpad_client)
set(BREAKPAD_WIN32_DEFINES
NOMINMAX
UNICODE