summaryrefslogtreecommitdiff
path: root/externals/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandre Bouvier <contact@amb.tf>2023-11-03 19:27:08 +0100
committerAlexandre Bouvier <contact@amb.tf>2023-11-30 16:54:00 +0100
commitd2bb9e9729bbdeb396817c2335c4fafbf5ac94a2 (patch)
treef09b1f3a4c07ffdd1ba36ad6993a3220c5fbdf0b /externals/CMakeLists.txt
parent127bfb81d5f03eb86f21053e6423083fec18d3fa (diff)
cmake: prefer system gamemode library
Diffstat (limited to 'externals/CMakeLists.txt')
-rw-r--r--externals/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/externals/CMakeLists.txt b/externals/CMakeLists.txt
index 04007a538..407c5c640 100644
--- a/externals/CMakeLists.txt
+++ b/externals/CMakeLists.txt
@@ -193,8 +193,10 @@ if (ANDROID)
endif()
endif()
-if (UNIX AND NOT APPLE)
- add_subdirectory(gamemode)
+if (UNIX AND NOT APPLE AND NOT TARGET gamemode::headers)
+ add_library(gamemode INTERFACE)
+ target_include_directories(gamemode INTERFACE gamemode)
+ add_library(gamemode::headers ALIAS gamemode)
endif()
# Breakpad