summaryrefslogtreecommitdiff
path: root/externals/getopt/CMakeLists.txt
diff options
context:
space:
mode:
authorbunnei <bunneidev@gmail.com>2018-01-18 01:37:17 -0500
committerGitHub <noreply@github.com>2018-01-18 01:37:17 -0500
commitbe0e14ab3e7b07b5d7879347114428f0beef595f (patch)
tree34521653cd5172d2af45214c3cce1f010842210a /externals/getopt/CMakeLists.txt
parent4ca5f0c14550bd196894058d5332311dbd0c7459 (diff)
parente710a1b9894d835d740ed63c03098fd637f61f63 (diff)
Merge pull request #84 from lioncash/cmake
CMakeLists: Derive the source directory grouping from targets themselves
Diffstat (limited to 'externals/getopt/CMakeLists.txt')
-rw-r--r--externals/getopt/CMakeLists.txt14
1 files changed, 6 insertions, 8 deletions
diff --git a/externals/getopt/CMakeLists.txt b/externals/getopt/CMakeLists.txt
index c8b745d55..ad7a2b363 100644
--- a/externals/getopt/CMakeLists.txt
+++ b/externals/getopt/CMakeLists.txt
@@ -1,11 +1,9 @@
-set(SRCS
- getopt.c
- )
-set(HEADERS
- getopt.h
- )
+add_library(getopt
+ getopt.c
+ getopt.h
+)
+
+create_target_directory_groups(getopt)
-create_directory_groups(${SRCS} ${HEADERS})
-add_library(getopt ${SRCS} ${HEADERS})
target_compile_definitions(getopt PUBLIC STATIC_GETOPT)
target_include_directories(getopt INTERFACE ${CMAKE_CURRENT_SOURCE_DIR})