summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorLioncash <mathew1800@gmail.com>2020-04-15 13:28:28 -0400
committerLioncash <mathew1800@gmail.com>2020-04-15 14:14:41 -0400
commit213fff67bcca6894602232bf721adf0b590bfcdf (patch)
tree7be77cfd49e35ede430a15a086d8957042c39273 /src/CMakeLists.txt
parent64b5985f0a034fb2b1988d960b009985f9929922 (diff)
CMakeLists: Make -Wreorder a compile-time error
This can result in silent logic bugs within code, and given the amount of times these kind of warnings are caused, they should be flagged at compile-time so no new code is submitted with them.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 9d0af02fd..e40e9b0a5 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -53,6 +53,7 @@ if (MSVC)
else()
add_compile_options(
-Wall
+ -Werror=reorder
-Wno-attributes
)