summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorMorph <39850852+Morph1984@users.noreply.github.com>2021-01-10 01:16:25 -0500
committerMorph <39850852+Morph1984@users.noreply.github.com>2021-01-10 01:16:25 -0500
commit25724898d081c1cef2876eaf6af4e120fa968f6a (patch)
treed3fb1c33fdb41b552979bbe4498ccf59459029a7 /src/CMakeLists.txt
parente07540264dbda32c98c330fddf0fa5ec3393bd3d (diff)
cmake: Enforce C4101
This matches GCC's -Wunused-variable
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index daf251d19..61adbef28 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -46,6 +46,7 @@ if (MSVC)
# Warnings
/W3
/we4062 # enumerator 'identifier' in a switch of enum 'enumeration' is not handled
+ /we4101 # 'identifier': unreferenced local variable
/we4265 # 'class': class has virtual functions, but destructor is not virtual
/we4388 # signed/unsigned mismatch
/we4547 # 'operator' : operator before comma has no effect; expected operator with side-effect