summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorMorph <39850852+Morph1984@users.noreply.github.com>2021-10-28 20:43:46 -0400
committerMorph <39850852+Morph1984@users.noreply.github.com>2021-10-28 20:43:46 -0400
commit3f8d74dec1a0cec48d4c8d3b60e9cc8e7f47c183 (patch)
treea8c6aed469d54a43a09ef30128d5c63217f85c25 /src/CMakeLists.txt
parentcd49907248d0708ae56d7131e4e1d97de01c5df2 (diff)
CMakeLists: Document the /GT compile option
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index a37ae37c1..63dd9febf 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -32,6 +32,7 @@ if (MSVC)
# /Zc:externConstexpr - Allow extern constexpr variables to have external linkage, like the standard mandates
# /Zc:inline - Let codegen omit inline functions in object files
# /Zc:throwingNew - Let codegen assume `operator new` (without std::nothrow) will never return null
+ # /GT - Supports fiber safety for data allocated using static thread-local storage
add_compile_options(
/MP
/Zi