summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorliamwhite <liamwhite@users.noreply.github.com>2022-12-03 14:10:06 -0500
committerGitHub <noreply@github.com>2022-12-03 14:10:06 -0500
commit75e16547f8977e8b2b07723b04bcc3cbe999d566 (patch)
tree7a7795d68f636d1a3f4972c3ea36c1d50db564c5 /src/CMakeLists.txt
parent22aff09b33941cdf907e474cb86117fef838abba (diff)
parent5b5612c1cc1ef7a4888e7c45e41b15433127a2e5 (diff)
Merge pull request #9300 from ameerj/pch
CMake: Use precompiled headers to improve compile times
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 4bd5aa50b..140415474 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -82,8 +82,9 @@ if (MSVC)
/wd4324 # 'struct_name': structure was padded due to __declspec(align())
)
- if (USE_CCACHE)
+ if (USE_CCACHE OR YUZU_USE_PRECOMPILED_HEADERS)
# when caching, we need to use /Z7 to downgrade debug info to use an older but more cachable format
+ # Precompiled headers are deleted if not using /Z7. See https://github.com/nanoant/CMakePCHCompiler/issues/21
add_compile_options(/Z7)
else()
add_compile_options(/Zi)