summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid <25727384+ogniK5377@users.noreply.github.com>2020-08-03 21:28:54 +1000
committerGitHub <noreply@github.com>2020-08-03 07:28:54 -0400
commit9b75481755c8d566bc666465d659115bba2b2578 (patch)
tree309d0ff37c8e68d178b65861abeb3bb0e8387f43 /src/CMakeLists.txt
parent6c7292de33702aababf60acbc58128bd060f81ab (diff)
ipc: Allow all trivially copyable objects to be passed directly into WriteBuffer (#4465)
* ipc: Allow all trivially copyable objects to be passed directly into WriteBuffer With the support of C++20, we can use concepts to deduce if a type is an STL container or not. * More agressive concept for stl containers * Add -fconcepts * Move to common namespace * Add Common::IsBaseOf
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 1e977e8a8..54dca3302 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -60,6 +60,7 @@ else()
-Wmissing-declarations
-Wno-attributes
-Wno-unused-parameter
+ -fconcepts
)
if (ARCHITECTURE_x86_64)