summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authortoast2903 <22451773+lat9nq@users.noreply.github.com>2023-06-21 22:57:40 -0400
committerlat9nq <22451773+lat9nq@users.noreply.github.com>2023-07-21 10:56:55 -0400
commitc1717b3f47af88a2c836ebbf2c4c3f773ae58cb0 (patch)
tree89247abd021459703f46c4ac7193f9a92230d9f1 /src/CMakeLists.txt
parentca8509d205d20d034c548489d729f65656da611d (diff)
cmake: Reposition preprocessor switch comment
Co-authored-by: Morph <39850852+Morph1984@users.noreply.github.com>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index e814cff19..2da983cad 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -35,6 +35,7 @@ if (MSVC)
# /volatile:iso - Use strict standards-compliant volatile semantics.
# /Zc:externConstexpr - Allow extern constexpr variables to have external linkage, like the standard mandates
# /Zc:inline - Let codegen omit inline functions in object files
+ # /Zc:preprocessor - Enable standards-conforming preprocessor
# /Zc:throwingNew - Let codegen assume `operator new` (without std::nothrow) will never return null
# /GT - Supports fiber safety for data allocated using static thread-local storage
add_compile_options(
@@ -48,7 +49,7 @@ if (MSVC)
/volatile:iso
/Zc:externConstexpr
/Zc:inline
- /Zc:preprocessor # Use standards-conforming preprocessor
+ /Zc:preprocessor
/Zc:throwingNew
/GT