summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorMorph <39850852+Morph1984@users.noreply.github.com>2021-10-28 20:40:13 -0400
committerGitHub <noreply@github.com>2021-10-28 20:40:13 -0400
commitcd49907248d0708ae56d7131e4e1d97de01c5df2 (patch)
treedc1408534aabdf9fe79ad55da36a84de96d56acd /src/CMakeLists.txt
parentfac2e073a1b73d74f439da685c50c65a88cf6134 (diff)
parent13471ddf86ef55cb62b27a51601cf9ac24797b8f (diff)
Merge pull request #7007 from FernandoS27/intel-options
Build System: Build with JCC Erratum Mitigation
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 6e66dc1df..a37ae37c1 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -44,6 +44,7 @@ if (MSVC)
/Zc:externConstexpr
/Zc:inline
/Zc:throwingNew
+ /GT
# External headers diagnostics
/experimental:external # Enables the external headers options. This option isn't required in Visual Studio 2019 version 16.10 and later
@@ -69,6 +70,10 @@ if (MSVC)
/we5038 # data member 'member1' will be initialized after data member 'member2'
)
+ if (ARCHITECTURE_x86_64)
+ add_compile_options(/QIntel-jcc-erratum)
+ endif()
+
# /GS- - No stack buffer overflow checks
add_compile_options("$<$<CONFIG:Release>:/GS->")