summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorMorph <39850852+Morph1984@users.noreply.github.com>2021-07-06 12:48:49 -0400
committerMorph <39850852+Morph1984@users.noreply.github.com>2021-07-06 12:50:09 -0400
commitebb82b0b8394781622afe132a0779dc25995b47b (patch)
tree5498cdf8076ea2715ab6efb5ad5bd0cd96945a04 /src/CMakeLists.txt
parentbf50345d4c13e34e69af0070632400b3472a1a11 (diff)
CMakeLists: Treat -Wsign-compare as an error on GCC/Clang
Treats (un)signed comparison mismatches as errors to be consistent with MSVC
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 65a4922ea..f8ec8fea8 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -82,6 +82,7 @@ else()
-Werror=missing-declarations
-Werror=missing-field-initializers
-Werror=reorder
+ -Werror=sign-compare
-Werror=switch
-Werror=uninitialized
-Werror=unused-function