summaryrefslogtreecommitdiff
path: root/src/common/CMakeLists.txt
diff options
context:
space:
mode:
authorYuri Kunde Schlesner <yuriks@yuriks.net>2015-08-17 18:25:21 -0300
committerYuri Kunde Schlesner <yuriks@yuriks.net>2015-08-24 22:16:28 -0300
commit0fcabd2b11a5b1d4d16f6f6bdf1efd54d2c45237 (patch)
treea1651d48113413e2de1e6e309362511b1ff7ffa8 /src/common/CMakeLists.txt
parentc7745408f77a17771c1a26efb981d79aa66c9f66 (diff)
Integrate the MicroProfile profiling library
This brings goodies such as a configurable user interface and multi-threaded timeline view.
Diffstat (limited to 'src/common/CMakeLists.txt')
-rw-r--r--src/common/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/common/CMakeLists.txt b/src/common/CMakeLists.txt
index e743a026d..7f3712efa 100644
--- a/src/common/CMakeLists.txt
+++ b/src/common/CMakeLists.txt
@@ -11,6 +11,7 @@ set(SRCS
logging/text_formatter.cpp
logging/backend.cpp
memory_util.cpp
+ microprofile.cpp
misc.cpp
profiler.cpp
scm_rev.cpp
@@ -43,6 +44,8 @@ set(HEADERS
make_unique.h
math_util.h
memory_util.h
+ microprofile.h
+ microprofileui.h
platform.h
profiler.h
profiler_reporting.h