summaryrefslogtreecommitdiff
path: root/src/common/CMakeLists.txt
diff options
context:
space:
mode:
authorMorph <39850852+Morph1984@users.noreply.github.com>2023-03-01 19:17:50 -0500
committerMorph <39850852+Morph1984@users.noreply.github.com>2023-03-05 01:41:19 -0500
commitbd09c825218aac9255643b9aa7c75f5ba156038c (patch)
tree76a7fb4a83ec09a927767d9f8c8a3342107c67cd /src/common/CMakeLists.txt
parentce8f4da63834be0179d98a7720dee47d65f3ec06 (diff)
common: Implement a high resolution steady clock
This implementation provides a consistent, high performance, and high resolution clock where/when std::chrono::steady_clock does not provide sufficient precision.
Diffstat (limited to 'src/common/CMakeLists.txt')
-rw-r--r--src/common/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/common/CMakeLists.txt b/src/common/CMakeLists.txt
index 56b247ac4..9f5d4c265 100644
--- a/src/common/CMakeLists.txt
+++ b/src/common/CMakeLists.txt
@@ -113,6 +113,8 @@ add_library(common STATIC
socket_types.h
spin_lock.cpp
spin_lock.h
+ steady_clock.cpp
+ steady_clock.h
stream.cpp
stream.h
string_util.cpp