summaryrefslogtreecommitdiff
path: root/src/common/CMakeLists.txt
diff options
context:
space:
mode:
authorameerj <52414509+ameerj@users.noreply.github.com>2022-12-18 18:08:20 -0500
committerameerj <52414509+ameerj@users.noreply.github.com>2022-12-19 18:07:51 -0500
commitcfc34dd41d63f45b0587d089b8ec7fc2ed27c04e (patch)
tree0966e445a3e2bd6552703b8243643f8275836d0b /src/common/CMakeLists.txt
parent88ba5a7f22b5783e6e19059e49b632d0bd9c8da0 (diff)
common: Add ScratchBuffer class
This class creates a default initialized heap allocated buffer for cases where value initializing members during allocation or resize is redundant.
Diffstat (limited to 'src/common/CMakeLists.txt')
-rw-r--r--src/common/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/common/CMakeLists.txt b/src/common/CMakeLists.txt
index f558f5a58..eb05e46a8 100644
--- a/src/common/CMakeLists.txt
+++ b/src/common/CMakeLists.txt
@@ -102,6 +102,7 @@ add_library(common STATIC
${CMAKE_CURRENT_BINARY_DIR}/scm_rev.cpp
scm_rev.h
scope_exit.h
+ scratch_buffer.h
settings.cpp
settings.h
settings_input.cpp