summaryrefslogtreecommitdiff
path: root/src/input_common/CMakeLists.txt
diff options
context:
space:
mode:
authorNarr the Reg <juangerman-13@hotmail.com>2022-12-20 20:27:34 -0600
committerNarr the Reg <juangerman-13@hotmail.com>2023-01-19 18:05:21 -0600
commitf09a023292e659af46d551b9b134d94d000a57c7 (patch)
treef34ef390cac9f32f7d807614505601635ac62e28 /src/input_common/CMakeLists.txt
parent5676c2e17fe895e450e185029991fc20bdf56ec5 (diff)
input_common: Add support for joycon input reports
Diffstat (limited to 'src/input_common/CMakeLists.txt')
-rw-r--r--src/input_common/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/input_common/CMakeLists.txt b/src/input_common/CMakeLists.txt
index d4307351c..4ab1ccbfb 100644
--- a/src/input_common/CMakeLists.txt
+++ b/src/input_common/CMakeLists.txt
@@ -64,6 +64,10 @@ if (ENABLE_SDL2)
helpers/joycon_protocol/generic_functions.cpp
helpers/joycon_protocol/generic_functions.h
helpers/joycon_protocol/joycon_types.h
+ helpers/joycon_protocol/poller.cpp
+ helpers/joycon_protocol/poller.h
+ helpers/joycon_protocol/rumble.cpp
+ helpers/joycon_protocol/rumble.h
)
target_link_libraries(input_common PRIVATE SDL2::SDL2)
target_compile_definitions(input_common PRIVATE HAVE_SDL2)