summaryrefslogtreecommitdiff
path: root/src/shader_recompiler/CMakeLists.txt
diff options
context:
space:
mode:
authorMatías Locatti <42481638+goldenx86@users.noreply.github.com>2023-06-12 16:50:59 -0300
committerGitHub <noreply@github.com>2023-06-12 16:50:59 -0300
commit42b2bc204f13966fd08af07dd08448bbefe14afa (patch)
tree5676f2516f33f855a02df13e89d401c8067fae21 /src/shader_recompiler/CMakeLists.txt
parentad8f122ab106a474bee26ca2f638cfe51256eb6e (diff)
parent2bb7ea436dc74f812a8092201dc597ed58ff3c7a (diff)
Merge pull request #10699 from liamwhite/conditional-barrier
shader_recompiler: remove barriers in conditional control flow when device lacks support
Diffstat (limited to 'src/shader_recompiler/CMakeLists.txt')
-rw-r--r--src/shader_recompiler/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/shader_recompiler/CMakeLists.txt b/src/shader_recompiler/CMakeLists.txt
index 03f69c191..07e75f9d8 100644
--- a/src/shader_recompiler/CMakeLists.txt
+++ b/src/shader_recompiler/CMakeLists.txt
@@ -216,6 +216,7 @@ add_library(shader_recompiler STATIC
frontend/maxwell/translate_program.h
host_translate_info.h
ir_opt/collect_shader_info_pass.cpp
+ ir_opt/conditional_barrier_pass.cpp
ir_opt/constant_propagation_pass.cpp
ir_opt/dead_code_elimination_pass.cpp
ir_opt/dual_vertex_pass.cpp