summaryrefslogtreecommitdiff
path: root/src/shader_recompiler/CMakeLists.txt
diff options
context:
space:
mode:
authorliamwhite <liamwhite@users.noreply.github.com>2022-12-03 14:10:06 -0500
committerGitHub <noreply@github.com>2022-12-03 14:10:06 -0500
commit75e16547f8977e8b2b07723b04bcc3cbe999d566 (patch)
tree7a7795d68f636d1a3f4972c3ea36c1d50db564c5 /src/shader_recompiler/CMakeLists.txt
parent22aff09b33941cdf907e474cb86117fef838abba (diff)
parent5b5612c1cc1ef7a4888e7c45e41b15433127a2e5 (diff)
Merge pull request #9300 from ameerj/pch
CMake: Use precompiled headers to improve compile times
Diffstat (limited to 'src/shader_recompiler/CMakeLists.txt')
-rw-r--r--src/shader_recompiler/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/shader_recompiler/CMakeLists.txt b/src/shader_recompiler/CMakeLists.txt
index ef09fe2b9..525b2363c 100644
--- a/src/shader_recompiler/CMakeLists.txt
+++ b/src/shader_recompiler/CMakeLists.txt
@@ -231,6 +231,7 @@ add_library(shader_recompiler STATIC
ir_opt/texture_pass.cpp
ir_opt/verification_pass.cpp
object_pool.h
+ precompiled_headers.h
profile.h
program_header.h
runtime_info.h
@@ -260,3 +261,7 @@ else()
endif()
create_target_directory_groups(shader_recompiler)
+
+if (YUZU_USE_PRECOMPILED_HEADERS)
+ target_precompile_headers(shader_recompiler PRIVATE precompiled_headers.h)
+endif()