summaryrefslogtreecommitdiff
path: root/src/shader_recompiler/CMakeLists.txt
diff options
context:
space:
mode:
authorMorph <39850852+Morph1984@users.noreply.github.com>2022-10-21 02:34:06 -0400
committerMorph <39850852+Morph1984@users.noreply.github.com>2022-10-22 15:02:04 -0400
commite6ab1f673b88b1af6bd966886249c7824ec5dbd4 (patch)
tree045b57ae71c4b8efe34be8504d86638f13cf61ac /src/shader_recompiler/CMakeLists.txt
parent93297d14d8fc5c8f73e8ccba5ca989590a453c05 (diff)
general: Enforce C4800 everywhere except in video_core
Diffstat (limited to 'src/shader_recompiler/CMakeLists.txt')
-rw-r--r--src/shader_recompiler/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/src/shader_recompiler/CMakeLists.txt b/src/shader_recompiler/CMakeLists.txt
index cbc1daf77..967da0791 100644
--- a/src/shader_recompiler/CMakeLists.txt
+++ b/src/shader_recompiler/CMakeLists.txt
@@ -248,7 +248,6 @@ if (MSVC)
/we4245 # 'conversion' : conversion from 'type1' to 'type2', signed/unsigned mismatch
/we4254 # 'operator': conversion from 'type1:field_bits' to 'type2:field_bits', possible loss of data
/we4800 # Implicit conversion from 'type' to bool. Possible information loss
- /we4826 # Conversion from 'type1' to 'type2' is sign-extended. This may cause unexpected runtime behavior.
)
else()
target_compile_options(shader_recompiler PRIVATE