summaryrefslogtreecommitdiff
path: root/src/shader_recompiler/CMakeLists.txt
diff options
context:
space:
mode:
authorMorph <39850852+Morph1984@users.noreply.github.com>2022-05-26 20:08:21 -0400
committerMorph <39850852+Morph1984@users.noreply.github.com>2022-06-13 18:19:23 -0400
commitefc89c032b18d149308a1f8c1a371f503edb91d1 (patch)
treedafbdc3a20ad07f24ee92c4583e3e84ecf01ab02 /src/shader_recompiler/CMakeLists.txt
parentd0328f49f1ebcc061ba2db34bb3ae49605ca97fa (diff)
CMakeLists: Make variable shadowing a compile-time error
Now that the entire project is free of variable shadowing, we can enforce this as a compile time error to prevent any further introduction of this logic bug.
Diffstat (limited to 'src/shader_recompiler/CMakeLists.txt')
-rw-r--r--src/shader_recompiler/CMakeLists.txt3
1 files changed, 0 insertions, 3 deletions
diff --git a/src/shader_recompiler/CMakeLists.txt b/src/shader_recompiler/CMakeLists.txt
index 4c76ce1ea..ae1dbe619 100644
--- a/src/shader_recompiler/CMakeLists.txt
+++ b/src/shader_recompiler/CMakeLists.txt
@@ -253,9 +253,6 @@ else()
-Werror
-Werror=conversion
-Werror=ignored-qualifiers
- -Werror=implicit-fallthrough
- -Werror=shadow
- -Werror=sign-compare
$<$<CXX_COMPILER_ID:GNU>:-Werror=unused-but-set-parameter>
$<$<CXX_COMPILER_ID:GNU>:-Werror=unused-but-set-variable>
-Werror=unused-variable