summaryrefslogtreecommitdiff
path: root/src/web_service/CMakeLists.txt
diff options
context:
space:
mode:
authorJames Rowe <jroweboy@gmail.com>2020-05-08 15:09:29 -0600
committerGitHub <noreply@github.com>2020-05-08 17:09:29 -0400
commitbc30a591ba7252e0c16d9c1b3c75a7073735bcae (patch)
tree2e88ab16d60c7df3e665bcf7c75c24683cb07189 /src/web_service/CMakeLists.txt
parent50c27d5ae1bfe6cff6f091f07d68ab7b8e394d9d (diff)
Replace externals with Conan (#3735)
* Remove git submodules that will be loaded through conan * Move custom Find modules to their own folder * Use conan for downloading missing external dependencies * CI: Change the yuzu source folder user to the user that the containers run on * Attempt to remove dirty mingw build hack * Install conan on the msvc build * Only set release build type when using not using multi config generator * Re-add qt bundled to workaround an issue with conan qt not downloading prebuilt binaries * Add workaround for submodules that use legacy CMAKE variables * Re-add USE_BUNDLED_QT on the msvc build bot
Diffstat (limited to 'src/web_service/CMakeLists.txt')
-rw-r--r--src/web_service/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/web_service/CMakeLists.txt b/src/web_service/CMakeLists.txt
index 0c9bb0d55..06ab7c59d 100644
--- a/src/web_service/CMakeLists.txt
+++ b/src/web_service/CMakeLists.txt
@@ -8,4 +8,4 @@ add_library(web_service STATIC
)
create_target_directory_groups(web_service)
-target_link_libraries(web_service PRIVATE common json-headers httplib lurlparser)
+target_link_libraries(web_service PRIVATE common nlohmann_json::nlohmann_json httplib lurlparser)