summaryrefslogtreecommitdiff
path: root/src/yuzu/CMakeLists.txt
diff options
context:
space:
mode:
authorlat9nq <22451773+lat9nq@users.noreply.github.com>2022-11-28 23:20:04 -0500
committerlat9nq <22451773+lat9nq@users.noreply.github.com>2022-11-28 23:21:14 -0500
commit0941ae0b617839a724a62c0a69914686e81f053f (patch)
tree28c379025386165643e3d9677f29ff13ff4b6d47 /src/yuzu/CMakeLists.txt
parent47b133c0b8364f5f79a5d44332523f2e9b9985d0 (diff)
CMake: Directly link to SDL2-static when appropriate
Trying to be lazy and alias SDL2 to SDL2-static causes issues in later versions of CMake. Just use the same condition to tell which one to use.
Diffstat (limited to 'src/yuzu/CMakeLists.txt')
-rw-r--r--src/yuzu/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/yuzu/CMakeLists.txt b/src/yuzu/CMakeLists.txt
index 0aa109dd3..060de0259 100644
--- a/src/yuzu/CMakeLists.txt
+++ b/src/yuzu/CMakeLists.txt
@@ -387,7 +387,11 @@ if (YUZU_USE_BUNDLED_QT AND QT_VERSION VERSION_LESS 6)
endif()
if (ENABLE_SDL2)
- target_link_libraries(yuzu PRIVATE SDL2)
+ if (YUZU_USE_EXTERNAL_SDL2)
+ target_link_libraries(yuzu PRIVATE SDL2-static)
+ else()
+ target_link_libraries(yuzu PRIVATE SDL2)
+ endif()
target_compile_definitions(yuzu PRIVATE HAVE_SDL2)
endif()