summaryrefslogtreecommitdiff
path: root/src/yuzu/CMakeLists.txt
diff options
context:
space:
mode:
authorlat9nq <lat9nq@gmail.com>2022-07-30 10:23:14 -0400
committerlat9nq <lat9nq@gmail.com>2022-09-04 21:36:35 -0400
commit12f7d42d32511955ee27875d42b6e8e3cda9e523 (patch)
tree842c5eadfa5d214a7fc17b4ef8ff86b7d4384e3d /src/yuzu/CMakeLists.txt
parent45b343d1d09f30193a1da52924ee83a834356fae (diff)
mini_dump: Address review feedback
Uses fmt::print as opposed to std::fprintf. Adds a missing return. static's a single-use function. Initializes structs as opposed to std::memset where possible. Fixes CMake linkage. Co-authored-by: Lioncash <mathew1800@gmail.com> mini_dump: Use a namespace Co-authored-by: Lioncash <mathew1800@gmail.com>
Diffstat (limited to 'src/yuzu/CMakeLists.txt')
-rw-r--r--src/yuzu/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/yuzu/CMakeLists.txt b/src/yuzu/CMakeLists.txt
index df0f64b83..29d506c47 100644
--- a/src/yuzu/CMakeLists.txt
+++ b/src/yuzu/CMakeLists.txt
@@ -214,7 +214,7 @@ if (WIN32 AND YUZU_CRASH_DUMPS)
mini_dump.h
)
- target_link_libraries(yuzu PUBLIC ${DBGHELP_LIBRARY})
+ target_link_libraries(yuzu PRIVATE ${DBGHELP_LIBRARY})
target_compile_definitions(yuzu PRIVATE -DYUZU_DBGHELP)
endif()