summaryrefslogtreecommitdiff
path: root/src/yuzu/CMakeLists.txt
diff options
context:
space:
mode:
authorJames Rowe <jroweboy@gmail.com>2018-07-02 11:10:41 -0600
committerbunnei <bunneidev@gmail.com>2018-07-02 21:45:47 -0400
commit6269a01b4e9963ffdaf98ddf5d5f2a90d49e58ff (patch)
treec69305f1bca02461e4af8dc20f0b47601f276fc0 /src/yuzu/CMakeLists.txt
parent0d46f0df122dbc9b9a9d9f97e2da6b1953ef939b (diff)
Add configurable logging backends
Diffstat (limited to 'src/yuzu/CMakeLists.txt')
-rw-r--r--src/yuzu/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/src/yuzu/CMakeLists.txt b/src/yuzu/CMakeLists.txt
index c662570d2..7de919a8e 100644
--- a/src/yuzu/CMakeLists.txt
+++ b/src/yuzu/CMakeLists.txt
@@ -30,6 +30,8 @@ add_executable(yuzu
debugger/graphics/graphics_breakpoints_p.h
debugger/graphics/graphics_surface.cpp
debugger/graphics/graphics_surface.h
+ debugger/console.cpp
+ debugger/console.h
debugger/profiler.cpp
debugger/profiler.h
debugger/wait_tree.cpp
@@ -81,6 +83,14 @@ if (APPLE)
target_sources(yuzu PRIVATE ${MACOSX_ICON})
set_target_properties(yuzu PROPERTIES MACOSX_BUNDLE TRUE)
set_target_properties(yuzu PROPERTIES MACOSX_BUNDLE_INFO_PLIST ${CMAKE_CURRENT_SOURCE_DIR}/Info.plist)
+elseif(WIN32)
+ # compile as a win32 gui application instead of a console application
+ target_link_libraries(yuzu PRIVATE Qt5::WinMain)
+ if(MSVC)
+ set_target_properties(yuzu PROPERTIES LINK_FLAGS_RELEASE "/SUBSYSTEM:WINDOWS")
+ elseif(MINGW)
+ set_target_properties(yuzu PROPERTIES LINK_FLAGS_RELEASE "-mwindows")
+ endif()
endif()
create_target_directory_groups(yuzu)