summaryrefslogtreecommitdiff
path: root/src/yuzu/CMakeLists.txt
diff options
context:
space:
mode:
authorNguyen Marc <nguyen_marc@live.fr>2023-10-14 08:46:05 +0200
committerNguyen Marc <nguyen_marc@live.fr>2023-10-14 08:46:05 +0200
commit63c5340cc4c64e81056f75aaffcca38f5235441f (patch)
treeab40c56f220fa9e137ddc16c493e3af2d7126180 /src/yuzu/CMakeLists.txt
parenta94371f67b9da4fd1f421b2088b4366e3e58a1ad (diff)
Revert "cmake: only add network component if qt used"
This reverts commit a94371f67b9da4fd1f421b2088b4366e3e58a1ad.
Diffstat (limited to 'src/yuzu/CMakeLists.txt')
-rw-r--r--src/yuzu/CMakeLists.txt5
1 files changed, 1 insertions, 4 deletions
diff --git a/src/yuzu/CMakeLists.txt b/src/yuzu/CMakeLists.txt
index 62392e993..34208ed74 100644
--- a/src/yuzu/CMakeLists.txt
+++ b/src/yuzu/CMakeLists.txt
@@ -384,10 +384,7 @@ if (USE_DISCORD_PRESENCE)
discord_impl.cpp
discord_impl.h
)
- target_link_libraries(yuzu PRIVATE DiscordRPC::discord-rpc httplib::httplib)
- if (ENABLE_QT)
- target_link_libraries(yuzu PRIVATE Qt${QT_MAJOR_VERSION}::Network)
- endif()
+ target_link_libraries(yuzu PRIVATE DiscordRPC::discord-rpc httplib::httplib Qt${QT_MAJOR_VERSION}::Network)
target_compile_definitions(yuzu PRIVATE -DUSE_DISCORD_PRESENCE)
endif()