summaryrefslogtreecommitdiff
path: root/src/yuzu/CMakeLists.txt
diff options
context:
space:
mode:
authorliamwhite <liamwhite@users.noreply.github.com>2023-10-29 23:41:13 -0400
committerGitHub <noreply@github.com>2023-10-29 23:41:13 -0400
commiteec3d356b69711b34145d16e669e25403880774e (patch)
tree55ea35e1fe80f8539ec7fd7ec2aaa3164a5679d1 /src/yuzu/CMakeLists.txt
parentadb090090605d3b1f4368fb0c7bc836206aa4bdf (diff)
parentd3997bad9b84579938d8cdb44b1d17cfab7bbcce (diff)
Merge pull request #11689 from liamwhite/breakpad
qt: implement automatic crash dump support
Diffstat (limited to 'src/yuzu/CMakeLists.txt')
-rw-r--r--src/yuzu/CMakeLists.txt10
1 files changed, 5 insertions, 5 deletions
diff --git a/src/yuzu/CMakeLists.txt b/src/yuzu/CMakeLists.txt
index 34208ed74..33e1fb663 100644
--- a/src/yuzu/CMakeLists.txt
+++ b/src/yuzu/CMakeLists.txt
@@ -227,14 +227,14 @@ add_executable(yuzu
yuzu.rc
)
-if (WIN32 AND YUZU_CRASH_DUMPS)
+if (YUZU_CRASH_DUMPS)
target_sources(yuzu PRIVATE
- mini_dump.cpp
- mini_dump.h
+ breakpad.cpp
+ breakpad.h
)
- target_link_libraries(yuzu PRIVATE ${DBGHELP_LIBRARY})
- target_compile_definitions(yuzu PRIVATE -DYUZU_DBGHELP)
+ target_link_libraries(yuzu PRIVATE libbreakpad_client)
+ target_compile_definitions(yuzu PRIVATE YUZU_CRASH_DUMPS)
endif()
if (CMAKE_CXX_COMPILER_ID STREQUAL "Clang")