summaryrefslogtreecommitdiff
path: root/src/yuzu/CMakeLists.txt
diff options
context:
space:
mode:
authorlat9nq <22451773+lat9nq@users.noreply.github.com>2023-05-28 21:46:02 +0000
committerlat9nq <22451773+lat9nq@users.noreply.github.com>2023-06-06 01:54:44 -0400
commitfc0c4db20d4161984a960a689afa0a08a5a4b401 (patch)
tree9271e436b5bbb08ea4d642a44aa50f788b6789e8 /src/yuzu/CMakeLists.txt
parent069d7e6be4faa6d10f7e2dd3765d93f925aa2f25 (diff)
yuzu-qt: Load Vulkan device info at startup
Loading it when the configuration opens now incurs a noticeable delay. We also don't need to rediscover the same data repeatedly each time the configuration opens. Moves vulkan device info discovery to yuzu's startup as opposed to the configure_graphics constructor.
Diffstat (limited to 'src/yuzu/CMakeLists.txt')
-rw-r--r--src/yuzu/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/yuzu/CMakeLists.txt b/src/yuzu/CMakeLists.txt
index 84d9ca796..733c296e4 100644
--- a/src/yuzu/CMakeLists.txt
+++ b/src/yuzu/CMakeLists.txt
@@ -210,6 +210,8 @@ add_executable(yuzu
util/url_request_interceptor.h
util/util.cpp
util/util.h
+ vk_device_info.cpp
+ vk_device_info.h
compatdb.cpp
compatdb.h
yuzu.qrc