summaryrefslogtreecommitdiff
path: root/src/yuzu_cmd/CMakeLists.txt
diff options
context:
space:
mode:
authorLioncash <mathew1800@gmail.com>2018-01-17 19:37:34 -0500
committerLioncash <mathew1800@gmail.com>2018-01-17 21:51:43 -0500
commite710a1b9894d835d740ed63c03098fd637f61f63 (patch)
tree7585a15cdf38ea2913a847c738c84e769e43ea77 /src/yuzu_cmd/CMakeLists.txt
parentee08c39b7251c6a037014b503ecf70ebf8dc5ed5 (diff)
CMakeLists: Derive the source directory grouping from targets themselves
Removes the need to store to separate SRC and HEADER variables, and then construct the target in most cases.
Diffstat (limited to 'src/yuzu_cmd/CMakeLists.txt')
-rw-r--r--src/yuzu_cmd/CMakeLists.txt25
1 files changed, 11 insertions, 14 deletions
diff --git a/src/yuzu_cmd/CMakeLists.txt b/src/yuzu_cmd/CMakeLists.txt
index 433e210b0..297dab653 100644
--- a/src/yuzu_cmd/CMakeLists.txt
+++ b/src/yuzu_cmd/CMakeLists.txt
@@ -1,21 +1,18 @@
set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${PROJECT_SOURCE_DIR}/CMakeModules)
-set(SRCS
- emu_window/emu_window_sdl2.cpp
- config.cpp
- yuzu.cpp
- yuzu.rc
- )
-set(HEADERS
- emu_window/emu_window_sdl2.h
- config.h
- default_ini.h
- resource.h
- )
+add_executable(yuzu-cmd
+ config.cpp
+ config.h
+ default_ini.h
+ emu_window/emu_window_sdl2.cpp
+ emu_window/emu_window_sdl2.h
+ resource.h
+ yuzu.cpp
+ yuzu.rc
+)
-create_directory_groups(${SRCS} ${HEADERS})
+create_target_directory_groups(yuzu-cmd)
-add_executable(yuzu-cmd ${SRCS} ${HEADERS})
target_link_libraries(yuzu-cmd PRIVATE common core input_common)
target_link_libraries(yuzu-cmd PRIVATE inih glad)
if (MSVC)