summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3465b7f73..1fd703408 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -419,7 +419,7 @@ add_subdirectory(externals)
if (ENABLE_QT)
if (NOT USE_SYSTEM_QT)
- download_qt(6.8.1)
+ download_qt(6.7.3)
endif()
find_package(Qt6 REQUIRED COMPONENTS Widgets Multimedia Concurrent Network)
@@ -674,4 +674,6 @@ if(ENABLE_QT AND UNIX AND NOT APPLE)
DESTINATION "share/metainfo")
endif()
-target_compile_options(discord-rpc PRIVATE -fpermissive)
+if (USE_DISCORD_PRESENCE)
+ target_compile_options(discord-rpc PRIVATE -fpermissive)
+endif()